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1.0 Introduction to Vectorworks

Vectorworks 2009 is a powerful drawing and designing program that can be utilized by a 
range of professions — from engineering and landscape through to set and lighting design 
and architecture. Vectorworks 2009 uses a combination of 2D and 3D tools and concepts to 
create sophisticated drawings and designs. It includes a database/reporting component and   
a built-in scripting language that allows you to make your own custom tools. 

Vectorworks can be used to create simple 2D drawings for joinery, a whole set of contract 
documents for a large commercial building, landscaping design or  a virtual 3D model of a 
building that you can walk around or fly through.

When you start Vectorworks 2009 it looks like this on a Windows machine:
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And like this on a Macintosh: 

Workspaces

The arrangement of the Menu Bar and Tool Palettes is 
called a workspace. There are workspaces for Architects, 
Landscapers, and Engineers. You can choose from a 
range of workspaces by going to the Tools Menu, clicking 
on workspaces and then clicking on the workspace that 
you want.

Go to the Menu bar.• 

Choose • Tools > Workspaces > Standard.

With the ease that you can change workspaces and create 
your own customized workspaces, you should get into the 
habit of changing the workspace to one that you like. 
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1.1 Vectorworks Parts

Menu Bar

These are the menus for the Standard Workspace. These menu commands instruct the 
computer to carry out the required action such as opening a document, rendering an 
object, etc. 

When you click on a name in the menu bar, the commands in that menu pop down. You will 
see that some are black and some are gray. The “grayed out” commands are unavailable or 
are inappropriate for the current tool or mode that you are presently working in. All of the 
available commands are shown in black. As you move the pointer down the list of commands, 
they will be highlighted. To choose the highlighted command just release the mouse button on 
a Macintosh, or click on the desired command on a Windows machine.

This is standard Macintosh and Windows interface so far. If you are currently using a 
computer all of this will be familiar. 

Help Menu

The last option on the menu bar is the Help menu. This command will open your web browser 
and display the Vectorworks Online Help. You do not need Internet 
access for this, as all the files are stored on your computer. 

Go to the Menu Bar.• 

Choose • Help > Contents (on a Windows machine) 

Help > Vectorworks Help...•  (on a Macintosh)
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You will see a list of bookmarks. 

Click on the topic, click on the • 
Index, or click on the search button 
to give you the ability to search for 
a specific word or phrase. 

View Bar

The view bar contains many of the view functions into one area. It 
allows you to save and retrieve saved views and choose settings 
for what you see on the drawing, the rendering, zoom and so on. 

You can edit the view bar by right mouse clicking (ctrl+click on a one button mouse), or you 
can click on the view bar menu. This allows you to choose the parts that you want to see. This 
bar is really useful, so watch the movie for a deep explanation.

Data Display Bar

There is the data display bar at the bottom of the screen that shows 
where the cursor is at the moment. 
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There is also a Data Display that can 
pop-up when you create something. 
This shows you the size of the object 
you are drawing, and it allows you to 
enter dimensions directly into the fields 
using the keyboard. This allows you to 
accurately control the size of the object 
you are drawing.

The Data Display bar and the Floating Display bar uses X and Y 
coordinates. X are horizontal dimensions and Y are vertical 
dimensions.

The angular dimensions do not follow surveyors bearings; 0º is 
across to the right, 90º is up the screen and -90º is down the 
screen.

If you type in a dimension on the floating data bar, it will be in your 
current units. If you want to type in a dimension using different units 
just type the dimension followed by the unit mark. For example, to 
enter 3 feet and 6 inches type in 3’6” and then hit the Return key. You can                             
also use simple arithmetic, e.g. plus (+), minus (-), divide (/) and multiply (*).

Tool Bar

The tool bar tells you what tool mode you have selected and 
sometimes has instructions about what to do next. The options         
or modes are displayed by icons in the tool bar along with a          
brief description of each mode as it is selected. 

When you select a tool, you have to check the tool bar to see what mode the tool is in. It may 
not be appropriate to what you want to do.
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1.2 Palettes

There are several palettes that control different aspects of your design;

The Attributes Palette controls the graphic attributes (line style, 
thickness, color, etc.) of the object that you are creating or modifying.

The Constraints Palette contains snaps to control the way that a tool    
is being used.

The constraint palette controls the way that you snap and the way that 
you constrain the creation of an object (to be perpendicular, parallel, 
etc.). If you do not turn on some of the constraints, you will not be able  
to snap onto any object. The most useful constraints to leave on all the 
time are the Snap to Object and Smart Points.

The constraints are turned on and off by clicking on them with the 
mouse. On the Macintosh, the constraints are darker when they are 
switched on. On the Windows machine, the constraints are lighter when 
they are switched on.

The Object Info Palette displays information about the object 
created or selected. You can use the Object Info Palette to change 
the size or location of an object, change the layer or class the 
object is assigned to, and you can add or edit database information.
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The Resource Browser allows you to place, import and organize 
resources (gradients, hatches, images, symbols, textures and 
worksheets).

 

The Resource Browser  can be used to look into other files to get 
these resources. 

The Navigation Palette gives you quick access to various aspects 
of your drawing (layers, classes, saved views and viewports). This 
palette is only available if you have Vectorworks Designer or one   
of the design series. It is not available if you have Fundamentals. 

The Visualization Palette is used to manage camera and lights. 
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Tool Palettes

The Basic Tool palette contains all the standard 2D tools for 
creating and editing. 

Tools in Vectorworks stay active until a different tool is chosen. So  

if you select the rectangle tool, it will stay active until you select a 

different tool. Clicking on the screen will start creating another 

rectangle even if you only want to select the zoom tool. The 

strategy is to select the tool first and then click on the screen. When 

you are finished with the tool, choose the next tool that you want.

The Tool Sets palette contains tools that are used for creating and 
modifying more advanced objects. The tools are grouped together 
in tool sets. The tool sets can be dragged off to make a separate 
tool palette, sometimes called tear-off palettes. 

All of these palettes are known as Floating Palettes because they 
can be moved anywhere on the screen by clicking onto their title 
bar and dragging the palette to the desired location. On Windows 
machines many of these palettes can be docked to either side of 
the screen or at the top of the screen. 

To find palettes, go to the Menu Bar.• 

Choose • Window > Palettes > and choose the palette 
that you want.

If the palette has a tick next, to its name then the • 
palette is open. If you choose the palette, again then 
the palette will close. To open the palette, choose it 
again.
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1.3 Filing

New File

To create a new Vectorworks document, from the                    • 
Menu Bar choose File > New...

This allows you to create a new file from a blank 
Vectorworks template. Using a template means that the 
new drawing will be exactly the same as the template in 
every way except for its name.

Template drawings can be created with all your favorite 
settings and saved as a template so that you don’t have 
to set them up in every new drawing that you create. 
They can even have drawn objects in them such as title 
blocks and symbols.

Saving Files

Once you begin a drawing in Vectorworks or open an existing file 
you will need to continually save your drawing. Until you save a file, 
anything you have drawn will not be stored. When you use the 
“Save” command you are storing the file onto your hard drive.

Go to the Menu Bar.• 

Choose • File > Save or Save As...

When you save a file the first time you get the opportunity              
to decide where you want to store the drawing. 

Make sure that you store the drawing into the correct • 
folder on your hard drive or in the correct folder on 
the server if you are using Vectorworks in a network.
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Opening Existing Files

When you create files with Vectorworks, you should remember to store them in a separate 
place, on your hard drive, from where Vectorworks is stored.

To open an existing drawing file, from the                            • 
Menu Bar choose File > Open...

Locate the file that you want and click on the Open button.• 

Recently opened drawings are shown on the File Menu.   
If the file you want is listed there, just select it from the list. 
Otherwise, use the Open command from the File menu.    
If the file has been open recently, then you can use the 
recent file command from the menu bar. Sa
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2.0 Getting Started

We are going to work on exercises that will explain basic concepts, ways of working, and how 
to draw quickly in 2D. If you are new to Vectorworks then you are advised to work through all 
the exercises. If you are familiar with Vectorworks then you should still review this chapter, just 
in case things have changed and to make sure that you are working effectively.

Most of the exercises are stored in their own files. These files contain information to make it 
easy for you to carry out the exercises. 

2.1 Setting Up Your Drawing

Go to the Menu Bar• 

Choose • File > New... 

On the Create Document dialog box, choose        • 
the option to Create blank document. We will    
start  with a blank document and set it up to suit    
the drawing we want to draw. 

Go to the Menu Bar.• 

Choose • File > Page Setup...

Set the • Page Setup to be one page  
vertically and one page horizontally. 

Click on the • Printer Setup button. 
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On a Macintosh, choose your printer. • 

This drawing is more horizontal than • 
vertical, so we need to set up the drawing 
as landscape rather than portrait (vertical).

On a Windows machine, choose your • 
printer. 

Set the drawing as landscape rather     • 
than portrait (vertical).

Click on the • OK button to get back to       
the Page Setup dialog box. 

Click on the • OK button.

Go to the • View Bar at the top              
of the screen.

Click on the • Fit to Page Area button. 

Go the Menu Bar.• 

Choose • File > Document Settings > Units...
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The first Tab controls the drawing • 
units. These are the units for your 
drawing and dimensioning. 

Choose the units that you want to • 
use from the Units pop-up menu.

Click on the • OK button. 

This drawing needs a layer scale that will allow us to draw • 
everything on the same page. This is a small bracket, so a  
scale of 1:1 will fit everything on the one page.

Right mouse click in the drawing area. • 

From the pop-up menu choose • Active Layer Scale...

Set the layer scale to • 1:1.

Click on the • OK button. 

2.2 Creating Objects

There is more than one way to create objects in Vectorworks.  
There are three main ways to create objects. We will create      
three rectangles using each of the three main ways to do so.

Go to the • Basic tool palette.

Select the • Rectangle Tool.
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Go to the • Tool Bar, the area just 
above the drawing area.

Click on the first mode.• 

Click once to start the rectangle.• 

Move your cursor down and to     • 
the right. 

Click once to finish the rectangle. • 

If you look at the • Object Info palette you will see the size          
of the rectangle that you have created. 

Use the • Object Info palette to change the width to            
50mm (2”). Type in the size you want and then hit the              
Tab key once to move to the next field on the Object                
Info palette. 
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Notice how the rectangle changed • 
size while one side of the rectangle 
stayed where it was. This is 
controlled by the box position 
control, the series of nine dots on 
the Object Info palette. The black 
dot represents the origin of the 
object.

Use the • Object Info palette to change the height to              
50mm (2”). Type in the size you want and then hit the                
Tab key once. Vectorworks will apply the new dimension              
to the rectangle. 

Notice how the rectangle        • 
changed size while one corner         
of the rectangle stayed where it 
was. This is controlled by the box 
position control, the series of nine 
dots on the Object Info palette. 
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Now we can use the • Object Info palette to move the rectangle 
on the screen. The middle part of the Object Info palette controls 
the position of the rectangle.

Set the box position (the black dot in the grid of nine) to the • 
bottom right by clicking on the bottom right radio button. 

Change • X and Y coordinates to 0.

Notice how the rectangle has • 
moved on the screen. 

This is the first way of drawing in • 
Vectorworks. It’s accurate because 
you change the size and location    
of the object after you have drawn 
it, but it’s not the fastest way. 

Drawing with the Floating Data Bar

The second way to draw objects is to use the Floating Data bar.

Go to the • Tool Bar. 

Right mouse click (control+click if • 
you have a one button mouse).

Check the settings for the Data Bar. • 
Click on the option to Use floating 
data bar. 

Right mouse click on the tool bar • 
and set each option to match the 
image. 
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Make sure the • Rectangle Tool         
is still active. 

Move to the center of the first • 
rectangle and click once. 

Move down to the right.• 

Notice the floating data display bar.• 

Hit the Tab key once. This gets you • 
into the Floating Data bar.

Type in the dimension you want   • 
for the X direction 50mm (2”).

Hit the Tab key once. • 

Notice the rectangle is fixed in the  • 
X direction.
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Type in the dimension that you want • 
for the Y direction -50mm (-2”).

Hit the Tab key once. • 

Notice the rectangle is fixed in      • 
the Y direction.

Click once to finish. • 

This method is faster than the last one, 
and it is  accurate. 

Drawing With Dialog Boxes

The third way to draw objects is to use the Create Object dialog 
box. Some tools have the ability to create an object if you double 
click on the tool in the tool palette. 

Double click on the • Rectangle tool. 

The Create Object dialog box opens.• 

Type in the dimension you want for the width field, • 50mm (2”).

Hit the Tab key once to move to the next field. • 

Type in the dimension that you want for height field, • 50mm (2”).

Set the box position (the black dot in the grid of nine) to the top • 
left by clicking on the correct radio button. 

Enter the co-ordinates for the origin of the rectangle: • 
X = 0 
Y = 0

Click on the • OK button.
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The new rectangle is placed in the 
correct position and to the correct size. 
This method is also fast and accurate 
and works well for some objects, but 
not all (e.g., continuous walls, 
polygons, etc.). 

2.3 Selecting and De-Selecting

Fundamental to using Vectorworks is the ability to select one or 
more objects. Without the ability to select an object you will not be 
able to move, rotate or edit the object. Most editing tools require 
you to select an object before you edit or manipulate it. Some other programs may            
work differently but not Vectorworks. You must select the object, then pick the tool. 

To select an object, use the 2D Selection Tool. Move the cursor to the object that you want to 
select and click once. You will notice that when you move the cursor over an object, the cursor 
changes shape and the object highlights. It does that to let you know that it recognizes an 
object that can be selected.

Use the • 2D SelectiontTool to select the first rectangle             
that we made. 

To select an object, move your • 
mouse to the edge of the object  
and click once with the mouse. 

Notice when you get near to an • 
object it highlights. This is called 
pre-selection, and it makes it easy 
to tell which object you will be 
selecting before you click on it. 
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Any selected object will be shown • 
by the highlight color. 

If you have selected the second or   
third mode on the tool bar, you will   
also see blue handles on the object. 
These allow you to interactively scale 
(reshape) the object. 

Click on the second rectangle that • 
we made and notice how the first 
rectangle is no longer selected. 

To de-select objects, click away • 
from everything; that is, click in a 
blank part of the drawing.

Selecting More Than One Object

Selecting more than one object lets you move or edit several 
objects, allows you to delete several objects and so on.

Use the • 2D Selection tool to select 
the first rectangle that we made. 

Sa
mp
le



 ©2008 Jonathan Pickup  |  Vectorworks Essential Tutorial Manual  21 

With your finger on the Shift key, • 
click on the second rectangle that 
we drew. Notice that you have two 
objects selected. 

With your finger remaining on the • 
Shift key, click on the third rectangle 
that we drew. Notice that you have 
three objects selected. 

To de-select objects, click away • 
from everything; that is, click in       
a blank part of the drawing.

Use the mouse to drag a marquee • 
(or gray box) around all the desired 
objects. 

To start the marquee, move   • 
beyond the top left corner of the 
first rectangle.
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Click and drag your mouse.• 

Drag the marquee over the first    • 
two rectangles. 

Let go of the mouse button. • 

Notice that only the first two • 
rectangles are selected. Only objects 
that are totally enclosed by the 
marquee will be selected this way.

Drag the same size marquee,     • 
this time holding the Option key     
on a Macintosh or the Alt key         
on a Windows machine. 
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Notice that everything you touch • 
with this marquee is selected. 

Deleting Objects

Select the object to be deleted.• 

Hit the • Delete key on the keyboard, 
use the Backspace key, or use the 
right mouse click and choose Cut 
or Clear. 
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Select and delete one of the other • 
rectangles.

Undo/Redo

If you draw something that you don’t want or if you                    
delete something and then change your mind, you can                 
undo your changes. 

From the Menu Bar choose•  Edit > Undo.

The last thing you did will be • 
undone. You can undo several 
things this way. There is a limit to 
the number of undo’s you can use, 
and this is set in your Preferences. 

The Redo command can be used to 
redo any step that you have undone.
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Cursor Shapes

The cursors in Vectorworks are designed to change shape to give 
you visual feedback as you move near objects, select tools and so 
on. To see the cursor change shape as you move over objects, try 
this: move the cursor to the corner of the rectangle until you notice 
the changes.

Go to from the Basic Tool palette.• 

Choose the • 2D Selection Tool.

Selection Arrow. The selection arrow 
is the cursor shape that you will see 
when you are away from all the objects 
on the drawing. 

Move Cursor• . When you move 
near an object, you get this cursor. 
By clicking and dragging with this 
cursor you can move an object, and 
this can be combined with the data 
display bar to move the object 
accurately.
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Snap Cursor• . When you move to 
the corner or center of an edge or 
center of the object, you get this 
cursor. By clicking and dragging with 
this cursor you can move the object 
from an exact point, in this case the 
corner. You can use this to snap to 
another object (use the information 
given in the screen hints).

Interactive Scaling (Reshape) • 
Cursor. After you have selected an 
object, move near one of the blue 
handles on the object. By clicking 
and dragging with this cursor you 
can scale an object. Combined with 
the data display bar you can rescale 
the object accurately.

To access the Interactive Scaling   
mode (it used to be called the “reshape 
cursor”) you need to select the correct 
mode on the tool bar.

The first mode on the tool bar allows 
you to move objects, but not stretch  
(or interactively scale).  

Select the second mode on the   • 
tool bar. This mode allows you to 
reshape single objects.

Select two rectangles. Notice that • 
you can’t reshape these.
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Select the third mode on the tool • 
bar. This mode allows you to 
reshape multiple objects.

Move your cursor to one of the blue • 
handles on the objects. By clicking 
and dragging with this cursor you 
can rescale most objects. 

2.4 Constraints

One of the most important constraints that you need to learn           
is the Smart Points. 

Make the • 2D Selection tool active.

Move your cursor to the top left • 
corner of the first rectangle. 

Do not click.• 

Move your cursor to the right. • 
Notice the dashed guide line.     
This is the smart points and you 
can use it to line up with objects   
on the screen to keep your 
drawings accurate. 
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2.5 Viewing

There are several viewing tools. Some of the tools are located on the tool palette and some 
are on the view bar at the top of the drawing window. We will look at the most useful tools and 
techniques below. 

Zooming 

The quickest way to zoom in and out of the drawing is to use the 
scroll wheel on your mouse. You can use this technique regardless 
of the tool you are currently using. 

Move the mouse over the object • 
you want to zoom in to.

Roll the mouse wheel forward to • 
zoom in. 

Roll the mouse wheel backwards to • 
zoom out. 

Fit to Page Area

The Fit to Page Area button is on the View Bar. It will show the 
current printable area of the design. Use this tool to show you the 
whole drawing within the printable area. 

Go to the View Bar. • 

Click on the • Fit to Page Area 
button. 

Whenever you get lost in the drawing, 

use the Fit to Page Area to get back 

quickly to your drawing.
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2.6 Creating, Modifying and Editing

Open the file called • Creating and Editing.sta.

 

The file is divided up into a series of layers. The exercises are 
designed to teach you how to draw and edit things in Vectorworks. 
Each tool you choose in Vectorworks has choices about how you 
use that tool. The choices are shown on the tool bar. The purpose 
of these exercises is to get you to use each mode for each tool.

When you have completed the instructions on the first layer, go to 
the layer button and choose the next layer down in the list. Do the 
same for all the layers until you get to the bottom of the layer list. 
Then you can move on to the next exercise.

Use these exercises as a starting reminder when you have taken a break from Vectorworks 
for any length of time. They are designed to allow you to develop some skills with 
Vectorworks. Then you can use them to refresh your memory.
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2.7 Text 

Getting Started

Most drawings require text so it’s important that you are able to create and edit text easily.

Open the file called • Annotation.sta 
from the exercises folder.

The file is a metal bracket that is 
missing dimensions and labels. 

Creating Text

Go to the Basic Tool palette.• 

Select the • Text Tool.

Go to the Menu Bar.• 

Choose • Text > Format Text...
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Set the Font, Size, Style and • 
Alignment for your text. 

These will be your default settings • 
for all your text from now on.

There are other ways to set the font, 

size and justification of the text. 

Commands on the Text Menu do this, 

but this dialog box is the quickest way 

to set up your text.

After text is created, you can edit the font, text size, style, etc., • 
from the Object Info Palette.

When you create text it can be one line or several lines. To make 

more than one line of text, use the Return key (the middle Enter key 

for Windows) key to start a new line. To finish a block of text, hit the 

Enter key (the far right hand Enter key on a Windows machine).
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Create the Drawing Labels

You have a drawing of a steel • 
bracket. 

Select the text tool and place a title • 
for each view, following the picture. 

These labels are Arial, 20pt text size. • 

The point sizes on drawings refers to • 
the final printed size of the text. 

Editing Text

The easier way to edit text is to start with the 2D selection tool. 
Double click on the text to edit it. If you double click on a text block, 
Vectorworks will select the text tool so that you can edit the text.

Go the Basic Tool palette.• 

Choose the • 2D Selection tool.

Double click on the text that you want to edit.• 

Highlight parts that you want to change and • 
type the new text. 

Change the first line to say “Construct  • 
from mild steel plate.”

When you are editing the text block, the tabs 
appear on the rulers at the top of the drawing 
area. If you have the rulers turned off, the  
tabs will appear just above your text block.

Click and drag to move the tab settings.• 
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Now you can use tabs to set up blocks of • 
text.

When you are finished, choose the • 2D 
Selection tool from the Basic Tool palette. 

Checking Spelling

Vectorworks now includes a tool to check the spelling of words in 
your drawings. This can be used in two ways.

Check selected text:

Select the block of text that you just edited, the block of notes.• 

From the Menu bar choose • Text > Check Spelling...

Vectorworks will check just the block of text that you • 
have selected.

If a word is not in the dictionary, then this dialog box will 
appear. If the word is spelled correctly, you can choose to 
add this to the dictionary by clicking on the Learn button.
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Check all spelling in the drawing:

Make sure that nothing is selected, by clicking away from • 
everything or by double clicking on the 2D Selection tool.

From the Menu bar choose • Text > Check Spelling...

Vectorworks can check the spelling in the entire file, or you can 
choose to filter what Vectorworks checks. 

Don’t forget that if you choose all text blocks Vectorworks will  

check all the text blocks on each layer in the entire file. This     

could take a long time to complete.

Find/Replace Text

This command can be used to look for a word or a phrase in your 
file and replace it with another word or phrase. It’s really useful if 
the client has changed a finish that you have placed all over the 
drawings, or if the engineer makes a change to the engineering 
requirements. You can get Vectorworks to change all occurrences 
of the particular word or phrase. 

From the Menu Bar choose • Text > Find-Replace Text...

Type in the text that you want to • 
find, bright red.

Type in the text that you want it • 
changed to, cool blue.

Click on the • Find/Replace button.
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Vectorworks tells you how many instances • 
were replaced.

The completed block of text.• 

2.8 Dimensions

Dimension values will depend on how you create the objects. If you create the objects 
accurately, they will dimension accurately. However, if you create the drawing roughly then 
when you dimension the drawing, the dimensions will be accurate to the objects that you’ve 
drawn, but the dimensions may not be what you were expecting. It is important that you create 
your models accurately and that you are very precise when dimensioning (use Object Snaps 
wherever possible).

Because we need to be able to snap accurately to the objects we are dimensioning, it will help 
you to zoom in. You will then easily see the drawing that you want to dimension.

Linear Dimensions

Zoom in to the plan view of          • 
the bracket. 
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Go to the • Dim/Notes Tool Set.

Choose the • Constrained-Linear Dimension tool. 

The tool bar shows the various options available to you (or modes 
of use). The first mode is used for dimensioning single items. The 
next mode is used for Constrained Chain Dimensioning. 

Go to the • Tool Bar.

Click on the first mode. • 

Move the cursor to the first point • 
that you want to dimension. Make 
sure that you snap onto the end    
of an object.

Move the cursor to the second  • 
point that you want to dimension 
and click once. This sets the 
distance to dimension.

This has defined the length of the 
dimension line, but you have to tell   
the computer where to place this, i.e.,  
where do you want the dimension to  
be displayed? 

Move the cursor up the screen. • 
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Move the dimension line on the • 
screen to place the dimension line 
where you want it to appear. Click 
once where you want to place the 
dimension.

If you see small squares at the end     
of the dimensions, they show the 
dimensions are associated with the 
objects. If you move the objects, the 
dimensions will change. 

Use the • Unconstrained Linear Dimension Tool to create 
unconstrained linear dimensions. Placing unconstrained 
dimensions is the same technique as placing constrained 
dimensions: click to start, click to define dimension length      
and click to place dimension. The difference is that  the       
angle between the first two clicks is important. 

Use these techniques to dimension • 
the rest of the plan.

Circular Dimensions

Go to the • Dim/Notes Tool Set.

Choose the • Radial Dimension tool. 
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The tool bar shows the various • 
options available to you (or modes 
of use). 

Click on the arc or circle that you • 
want to dimension. 

Move to the place where you want • 
to place the dimension.

Click once. • 

The dimension is placed at your  • 
last click.
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Angular Dimensions

Go to the • Dim/Notes Tool Set.

Choose the • Angular Dimension tool. 

The tool bar shows the various • 
options available to you (or modes 
of use). 

Click on the first line you want to • 
dimension from. Notice that the 
cursor changes shape when you 
get near the line.

Click on the second line for           • 
the angle. Notice that the cursor 
changes shape when you get    
near the line.
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Click once where you want to   • 
place the angle dimension. 

The dimension is placed at your  • 
last click.

Moving a Dimension Line

Dimensions can be modified easily. You can move the position of   
a dimension line or change its location in relation to the drawing.

Go to the Basic tool palette.• 

Choose the • 2D Selection Tool. 

Move your cursor to the line part   • 
of the dimension that you want to 
move. Your cursor will change to    
a reshape cursor when you are 
near the dimension line. 
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Click and hold your mouse button • 
down. Drag the mouse, but do not 
let go of the mouse button.

Drag the dimension to where      • 
you want it. When you are happy 
about its position, let go of the 
mouse button.

You can move the dimension      • 
text as well. 

Click and drag on the number     • 
that you want to move.

Move to the new location and • 
release the mouse button. The 
dimension text will be at the new 
location. 
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Changing the Dimension Standard

Vectorworks comes with several built-in dimension standards to 
choose from. To change the dimension standard (the look and feel 
of the dimension):

Select the dimension that you want to change.• 

On the Object Info Palette select the • Dim Standard  pop-up. 

Choose the dimension standard that you want to apply to       • 
the dimension.

The  dimension takes on the      • 
new standard. 
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Callout Tool

The Callout Tool is used to place notes on the drawing with arrows 
pointing to the object that the notes refer to. 

Go to the Basic tool palette. • 

Select the • Callout Tool.

Go to the • Tool Bar. 

Click on the • first and fourth 
modes.

Click once for the position of        • 
the text.

Click once for the start of the • 
angled line (Vectorworks calls      
this the shoulder).

The last click is where you want   • 
the note to point to.
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Enter the text of the note in the dialog box.• 

Click on the • OK button, or hit the Enter  
key (far right-hand side of the keyboard).

Completed Callout.• 

Any Callout note can be edited using 

the Object Info Palette by clicking on 

the Edit Note button or by double 

clicking on the callout with the 2D 

Selection tool. Sa
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2.9 2D Drawing Exercise

The aim of this exercise is to bring together many of the 2D drawing 
tools and techniques into one drawing. We want to complete a 2D 
drawing of a steel bracket.

Start with a new file. 

Go to the Menu Bar.• 

Choose • File > New... 

On the Create Document Dialog box, choose the • 
option to Create Blank Document. We will start with   
a blank document and set it up to suit the drawing 
that we want to draw. 
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Go to the Menu Bar.• 

Choose • File > Page Setup...

Set the Page Setup to be one page • 
vertically and one page horizontally. 

Click on the • Printer Setup button. 

On a Macintosh, choose your printer. • 

This drawing is more horizontal                • 
than vertical, so we need to set up              
the drawing  to be landscape rather                 
than portrait (vertical).

On a Windows machine, choose             • 
your printer. 

Set the drawing to be landscape            • 
rather than portrait (vertical).
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Click on the • OK button to get back to the 
Page Setup dialog box. 

Click on the • OK button.

Go to the View Bar.• 

Click on the • Fit to Page Area button. 

Go to the Menu Bar.• 

Choose • File > Document Settings > Units...

The first tab controls the drawing • 
units. These are the units for your 
drawing and dimensioning. 

This is the Macintosh version.• 

This is the Windows version.• 
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The second tab controls the primary • 
dimensioning settings. 

This is the Macintosh version.• 

This is the Windows version.• 

The third tab controls the   • 
secondary dimensioning settings. 

This is the Macintosh version.• 
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This is the Windows version.• 

Click on the • OK button to return       
to the drawing. 

This drawing needs a layer scale that will allow us to draw 
everything on the same page. This is a samll bracket, so   
everything will fit on the page with a scale of 1:1.

Right mouse click in the drawing area. • 

From the pop-up menu choose • Active Layer Scale...

Set the layer scale to • 1:1.

Click on the • OK button to return to 
the drawing. 

Go to the Menu Bar.• 

Choose • Tools > SmartCursor Settings...
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Click on • Grid.

This opens a dialog box for us to set 
the snap and reference grids to make   
it easier to draw. The reference grid is 
the blue lines in the drawing area.

Click on the • OK button to return     
to the drawing. 

If this was a typical drawing set up, you could save this as a 
template file. A template file makes it easy to get started with      
your projects because the file is set to the units, page size,          
and orientation that you want. 

Go to the Menu Bar.• 

Choose • File > Save As Template...

Save the file into your templates • 
folder. 

If this is a typical file, name the file: • 
Default.sta 

You may have to confirm that you • 
want to replace the old one. 

We are ready to start drawing. This exercise is designed to bring together the lessons that you 
learned in the earlier 2D drawing exercises. You will find there are no step-by-step instructions. 
This is done on purpose to make you work at this exercise. If you are struggling then you need to 
go back to the creating and editing exercises and repeat them. (See pages 27-52)
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Go to the Constraints Palette.• 

Make sure that your • Snap to Grid Constraint is turned off. This makes it 
easier to place things on this drawing where we want them, rather than 
snapping to a grid position.

Double click on the • Rectangle tool. This opens a dialog           
box for us to type in the size of the line that we want. 

Choose the option • Position at Next Click. 

Place the line in the upper left      • 
hand part of the drawing. 

Zoom into the rectangle after you • 
have placed it. 
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Go to the Basic Tool palette. • 

Choose the • Split Tool.

Go to the • Tool Bar.

Click on the last mode. • 

Start at the top right corner of        • 
the rectangle. 

Click once. • 

Move down to the left.• 

Hold down the shift key to   • 
constrain the trim line to 30º.

Click once.• 

Move the cursor to the left. The • 
black arrow has to point to the left. 

Click once. • 

Vectorworks cuts the rectangle      • 
and removes the bit that we don’t 
want. You’ll notice that there is a 
line missing.
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On the Object Info Palette there is a tick box that will                  • 
fill in our missing side. 

Click on the • Closed tick box.

This is the easy way to close             • 
a polygon. 

Go to the Basic Tool palette.• 

Select the • Fillet Tool.

Go to the • Tool Bar.

Choose the • third mode. 

Click on the • Fillet Preferences button 
(the last button on the tool bar).
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Set the Fillet Tool Preferences to • 6mm (¼ in.). 

Start at the top left corner. Click • 
once on the horizontal line. 

Click once on the vertical line.• 

The corner is filleted.• 
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Fillet the bottom left corner.• 

Fillet the bottom right corner.• 

Go to the • Tool Bar.

Change modes to the • second 
mode before filleting the top        
right corner. 

Notice that the two lines are left. • 
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Use the • 2D Selection Tool to select 
just the two small extended lines.

Change the line style to a small • 
dashed line by using the Attributes 
Palette. 

Double click on the • Circle tool.

Set the circle to be • 12mm (½ in.) diameter. Make 
sure that Center At Next Click is turned on. 
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Move to the bottom left of the • 
bracket. Use the smart point to help 
you to align to the bottom corner. 

Hit the • G key to get a Floating 
Datum (a temporary measuring 
point). 

You might get a dialog box that you 
have to close. 

Click on the option • Don’t show   
this dialog again. 

Use the • Tab key to get into            
the Floating Display Bar. 

Type in • 12mm (½ in.).

Hit the • Tab key.

Type in • 12mm (½ in.).

Hit the • Return or Enter Key        
(the one near the letters).

This gives you guides for placing 
your circle. 

Move to the intersection                  • 
on the two lines.

Click once. • 

Your circle is in the correct location. 
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Double click on the • Circle tool.

Set the circle to be • 12mm (½ in.) diameter. Make sure that 
Center At Next Click is turned on. 

Move to the top left of the bracket. Use the smart point to help • 
you to align to the top corner. 

Hit the • G key to get a Floating 
Datum.

Use the • Tab key to get into            
the Floating Display Bar. 

Type in • 12mm (½ in.).

Hit the • Tab key.

Type in • -12mm (-½ in.).

Hit the • Return or Enter key           
(the one near the letters).

Click once. • 

The next circle is offset from each side by • 12mm (½ in.) .                       
The easy way to do this is to use the Smart Edge Constraint. 

Double click on the • Smart Edge.
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Click on the • Snap to Offset option 
and enter the distance, 12mm (½ in.). 

Click on the • OK button.

Double click on the • Circle tool.

Set the circle to a • 12mm (½ in.) 
diameter. 

Move your cursor to the top line. • 

DO NOT CLICK• , hit the T key once. 

When you move away from the top • 
line, you will see an offset guide. 

Move to the right-hand line, and     • 
hit the T key once. 
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When you move away from the  • 
side line and you will see an offset 
guide. 

Move your cursor until you find     • 
the Offset/Offset screen hints. 

Click once. • 

Now your last circle is in place. • 

Turn off the • Smart Edge constraint 
by clicking on it once. 

If you haven’t saved the file lately, • 
save it now.

To draw the front view of the bracket we 
will use the rectangle tool. The Smart 
Points constraint will help us here. 

Draw a line from the center of the • 
right fillet out to the right. 
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Select the Rectangle tool. • 

Touch the edge of the bracket.• 

Move down the screen.• 

Click to start your rectangle.• 

Remember that you can use the • 
Tab key to get into the Floating 
Data to control the exact thickness 
of the plate, 10mm (0.4”). 

Move your mouse up to the • 
intersection of the new line and    
the bracket. 

Click once. • 
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Your bracket is created with the • 
correct length and the correct width.

Delete the small line. • 

Use the rectangle tool to draw    • 
the first hole. 

Touch the start point on the • 
existing hole.

Move down to the top of the      • 
new rectangle. 

Click once. • 

Touch the other side of the circle.• 

Move down to the bottom of the • 
front view. 

Click once.• 
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Change the rectangle to dotted • 
lines and no fill by using the 
Attributes Palette. 

Use the rectangle tool to           • 
draw the second hole. 

Touch the start point on                   • 
the existing hole.

Move down to the top of                • 
the new rectangle. 

Click once. • 

Touch the other side of the circle.• 

Move down to the bottom of the • 
front view. 

Click once.• 
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Change the rectangle to dotted • 
lines and no fill with the Attributes 
Palette. 

Select the plan view of the bracket.• 

Use the • Attributes Palette to 
“heavy up” or thicken the outline       
of the bracket. 
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Use the • Attributes Palette to 
thicken the outline of the bracket      
in front view. 

If you haven’t saved the file lately, • 
save it now.

Draw a • 45º guide line to help         
you to create the side view. 

Either draw construction lines to • 
help you out, or use the floating 
datum to help you to line up with 
the plan and front view. 
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Use the SmartCursor cues to        • 
line up horizontally.

And use the SmartCursor cues         • 
to line up vertically.

Draw the side view and the holes. • 
Use the Attributes Palette to get the 
line weights and line styles to match 
the other views. 
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Delete any construction lines         • 
that you don’t need. 

Dimension and annotate the • 
drawing. 

If you haven’t saved the file lately, • 
save it now.

We can print the drawing now. The drawing should be inside the gray border. The gray border 
is the printable area for your drawing. Anything outside this area will not print. 

Go to the Menu Bar.• 

Choose • File > Print... 
If you are connected to a printer, you will be able to print this drawing. At the start of this 
exercise we set up the page for printing and we choose a printer. This is the printer you 
should send the drawing to.

Click on the • OK button. 
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