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Introduction

Hi, I’m Gregg Hillmar. I’ve been working for many years as a scenic 
and lighting designer for theatre and other entertainment industries.  
In addition to a vigorous freelance career, I have taught at a variety  
of graduate and undergraduate institutions before happily settling  
at Randolph-Macon College in Ashland, Virginia. I’ve been using 
Vectorworks, and before that MiniCad, since about 1992, and  
“full-time” since 1994 or so — based on the last hand-drafted show  
in my portfolio. I first experimented with drawing light plots and scenery 

in MacPaint, having bought my first Macintosh computer in late 1984. Subsequently I tried 
MacDraft, Canvas, and GenericCADD among others, but it was not until discovering MiniCad 
that I felt giving up the pencil was in order.

Fast forward several years, and I’m now asked to demonstrate Vectorworks by Nemetschek 
North America, the publishers of Vectorworks, at their booth at industry conventions including 
LDI, USITT, and SETC. I have also worked as a Vectorworks trainer and consultant for private 
corporations and public training seminars sponsored by theatrical organizations and educa-
tional institutions. I’ve also done several Spotlight training sessions for NNA’s own sales and 
tech support teams, including taking them into theatres to witness first hand the spaces, 
materials, and tools of our industry.

This book will take a quick look at how I use Vectorworks to draft lighting plots. My way is not 
the only way. It’s not right or wrong. It’s just the way my practice and workflow have evolved 
over the fifteen years I have been using Vectorworks. I’m reminded of Stanley McCandless’s 
famous (at least to lighting designers) book A Method of Lighting the Stage, which to many 
designers turned into the method of lighting the stage. There is no “the” implied here. My 
approach is not the end-all and be-all, but it works for me. This book reflects my approach. 
Feel free to adapt my ideas to your own approach.

My point of view is that theatrical drafting is about communication. It is somewhat free of the 
structures used by commercial draftsmen in strictly architectural practice, but the end results 
are the same. We need to communicate clearly and concisely with those we work with. They 
need to be able to understand in an instant what they are looking at and be able to use that 
information. Choices we make in line weight, dashes, hatches, symbols and all of the other 
graphics are the language in which we communicate. Page layout and choices of what is on 
each plate in a set of drawings puts that language into context. The composition of the page 
refines that context. We can turn out really beautiful drawings, full of style and grace, but 
unless the shop can read them and instantly understand what is being communicated, the 
drawings are just so much paper waiting to be recycled. 

This book will certainly reflect my drafting style, as taught to me primarily by William H. Lockey 
(University of Richmond), and John Rothgeb and David Nancarrow (University of Texas 
Austin). My style has been further refined by many years of drafting scenery and lighting for 
the theatre, and working with myriad theatre artists who also draft. I’ve used (some may say 
stolen) what I like, and vowed to never do what I don’t like. Note that this is not a book about 
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Luckily, most light plots are not so many sheets. The plot, printed, is ready to be distributed to 
the Master Electrician and anyone else who needs it.

But wait: there is still the paperwork to finish. Information about each and every light is noted 
—by hand In Ye Olde Days on blank forms drawn and reproduced for just such purposes. 
Photocopy those for all involved if there was a photocopy machine available. Hope that there 
are no changes “on the fly,” which necessitate changing multiple sheets of paper—by hand— 
for multiple people. John McKernon, author of Lightwright, tells the story of watching all of  
his tour mates go off to the beach while he remained in the hotel updating the plot and 
paperwork…again.

It all was a rather time- and thought-consuming process. And it was not always fun.

I was in graduate school in the mid-80s when a touring dance company came through the 
Performing Arts Center. I remember vividly a discussion with the Production Manager, who 
was travelling with one of the very first PCs. He could save and update his paperwork as 
quickly as he could type, and then print out new versions right then and there. The implica-
tions were obvious, and it was not long after that designers began working on preparing and 
presenting visual information on computers as well. Fast forward many years, and we now  
do what is basically the same process as outlined above, but with much less trauma and 
stress, not to mention much less drafting tape.

Still, the way I approach drafting a light plot in Vectorworks is very similar to the way we used 
to approach drafting by hand. Design Layers in Vectorworks are our sheets of vellum; we are 
always drawing on a virtual sheet of vellum. At the end of the process, we will “copy up” what 
we want to print to a Sheet Layer, placing elements there for visual communication. Line 
weight still gives us as much information as always, so it too gets “reproduced” in our digital 
approach. Communication is still the main point of drafting a light plot.

Vectorworks Basics

Opening a new document

I’ll assume you have knowledge of your particular computer and operating system (OS). I’ll 
also assume you have installed Vectorworks on your computer and have a working knowledge 
of “the basics.” Again, most of the references made in this book are Macintosh-based since 
that is what I use, but “…click on the selection tool,” or “…in the Modify menu” should be the 
same regardless. I’ll note that there is a Mac/Windows dictionary in the Vectorworks manual 
that lists exact key and menu commands cross-referenced for each platform.

When Vectorworks is started, the current behavior in Vectorworks 2009 is that no document is 
opened. Choosing “New” from the File menu pops up a dialog box asking what to do. “Create 
blank document” does just that, creating a “virgin” untitled document. Under “Use document 
template,” choices can be made from files provided by NNA. In addition, a “default.sta” can be 
created and saved to be used at any time. The advantage of this is that any user can set up 
their own default to look like anything they want; choose scale, paper size, default layer and 
class assignments, default symbols, textures, and Vectorworks and document preferences, 
then save that setup as the default. Every time that document is opened, that setup will be 
used. Over the next few pages, I’ll talk about my preferred setup, and then I’ll talk about 
saving the default file.

When I open a new file, I see the following layout:

Illustration 1
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Workspaces

Workspaces define how the menu commands, tools, and palettes are organized and define 
the “hot keys;” shortcuts that evoke particular tools or commands. Vectorworks ships with  
a series of predefined workspaces that can be chosen from the Tools>Workspaces menu. 
Exactly which ones are available will depend on which modules of Vectorworks are installed. 
I’ll assume the Spotlight module is installed, so that is the workspace to start with. The image 
above (Illustration #1) actually shows the Spotlight Workspace. 

The nice thing about workspaces is that they are completely customizable. In the simplest 
case, if any of the palettes are moved, their new position will be remembered. Rather than 
changing the default shipping version of that workspace, Vectorworks creates a new copy  
of it in the application support folder. Where that folder is will depend on the OS in use, but 
Vectorworks will always look here first and use that copy of the Workspace.

Vectorworks does allow the tools, commands and menus to be customized to best suit 
individual working habits and to add additional tools or commands to the Workspace. I,  
for example, move often from my laptop by itself to my laptop with an additional monitor  
and therefore have two main workspaces customized and saved. Right now, using  
Vectorworks2009, one of my workspaces is called gregg09_1scr, and the other is called 
gregg09_2scr. Both have custom menus, custom tool palettes, and saved scripts—the 
difference being where the palettes are located on the screen. When using two screens,  
I keep important palettes open and visible on the right monitor while the drawing area and 
basic tools fill the space on the left monitor. That layout is saved as gregg09_2scr. On the 
road when using just the laptop, I switch to gregg09_1scr where the palettes are collapsed  
up on top of the Drawing Window bar. On the Mac, palettes cannot dock into the window  
as in the PC world; each remains a separate floating window. But they can be collapsed  
and positioned as out of the way as possible. 

Palettes

Tools used in Vectorworks are organized in palettes. In Vectorworks 2009, the basic 2D tools 
are in the Basic Palette. Other tools are arranged under tabs in the Toolset Palette. By clicking 
on the tab, tools in that category are displayed.

All of the tool palettes are “tear-offs” in that clicking on the tab bar of the palette, one can drag 
the tools anywhere on the screen so that they are not just in the Tool Palette. Moving the Tool 
Palette closer to where the actual work is being done saves a lot of mousing back and forth. 
Using “hot keys” will also save mousing—a keystroke can select a tool or execute a menu 
command. Learning the hot keys is a very good way to save time and energy while drafting. 
The key combination can be seen in the pop-up tool tips. 

On the bottom of palettes is a pull-down menu which lets me choose whether I see the tools 
as colored icons, by name, or by both icon and name.

On the Mac, the Tool Palettes are separate “windows” that can be arranged anywhere on  
the screen, or screens. They can be made visible or invisible via key commands or via the 
Palettes Menu. They can be collapsed by double-clicking in the title bar. In Windows, the 
palettes can be free-floating windows, docked into the main Vectorworks window, or hidden 
using the Auto Hide feature.

Palettes can be manually reorganized to fit in any workflow. In addition to the Basic and the 
Toolset Palettes, always on the left of my main screen, the palettes I use most often are the 
Navigation Palette, Resource Browser, the Attributes Palette, and the Object Info Palette.  
I keep them open always, collapsed at the top of the screen when working with one screen,  
or open on the second screen to the right of the Drawing Window when using two screens. 
Vectorworks will remember the last location of all palattes and put them there when reopened. 
That is the first step in defining how to best work with Vectorworks. The second step is to 
customize Menus. 

The custom scripts and tools that I use regularly have been added to an individualized  
tool palette called “greggs” and to a menu called “gregg09_2 (on my two-screen workspace) 
named so I know at a glance what workspace is active. In addition, I’ve gathered menu 
commands relating to Spotlight into one menu; Vectorworks ships with these menu  
commands organized by function in many other menus. 

Scripts can be written by anybody and included in menus or as custom tools. Vectorworks 
includes a scripting language that can accomplish many things. Not a coding guru? Many 
repetitive commands can be “memorized” and saved as a simple script to be used again  
and again. The Spotlight Find and Modify command, and the Custom Modification…  
and Custom Selection Tools include this option in the dialog box itself.

There are also freeware and shareware commands and tools readily available from  
other users. To find many of them, start with the community page at Nemetschek’s site,  
www.nemetschek.net/community/index.php. There are several theatre lighting specific  
scripts and tools available there and elsewhere. AutoPlot, for example, is just such a set of 
scripts. It is available via the community site mentioned above, or go right to the source at 
www.autoplotvw.com. I never leave home without it. While at the community page mentioned 
above, also visit the Mailing Lists link, where there is a link to the Vectorworks Theatre Mailing 
List. Here you will find discussion of Vectorworks as used in theatre. Many questions are 
asked and answered here, including scripting theatre-specific macros. A member of that list 
working in a nontraditional space recently asked about numbering instruments in a clockwise 
fashion. Sam Jones, author of the AutoPlot macros, had a script written and posted within a 
day or so of the request. There is a wealth of information here! 

Once acquired or made and saved, any of these scripts and tools can be added to a custom 
workspace. I’ll also rearrange the existing commands and tools to best suit my workflow. To  
do so in Vectorworks, I select menu: Tool>Workspaces>Workspace Editor

Sample
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So, for example, the Vectorworks folks decided logically to put the Convert to Lighting Position 
command with the other Convert… commands. I’d rather have all of my Spotlight tools in one 
place. So I’ve created a Spotlight menu, and then I moved all the Spotlight commands, 
including the Convert to Lighting Position command, into that new menu. Unless I specifically 
remove the command from the other menu, it will stay there as well.

Within the Workspace Editor, “hot key” commands can be added or changed from the 
Vectorworks defaults. Some commands that I use often have no key commands, so I’ve given 
them one. Select the command in the Menus frame of the Workspace Editor, as I’ve selected 
the Add Surface command in Illustration #3. Then type in the desired key command with the 
proper radio button checked—in this case Command+Option+Shift+“A.” If the key command  
is in use in Vectorworks elsewhere, I’ll get a dialog asking if I really want to change it. If the 
sequence is used by the OS, the OS command usually trumps the application use.

If desired, I can even edit the Document Contextual Menu—the menu that pops up when 
right-clicking in the document—and I can edit the Object Contextual Menu as well. I usually 
put my most-used AutoPlot commands in the Contextual Menu for easy access. 

The biggest frustration with this process is that you can only move one command at a time 
into menus. AutoPlot contains over 50 commands. Rather than being able to select and move 
all of them to a new menu, each must be moved separately.

Once done rearranging menu commands, I’ll click on the Tool tab, and do the same with Tool 
Palettes. I’ve created a new Tool Palette named “gregg,” and moved most-used tools into it in 
addition to new tools I’ve created or downloaded from other sources. I can arrange them into 

Initially, I’ll choose to work on a copy of the existing Workspace, which as suggested before, 
should be the Spotlight Workspace. I’ll choose to “Edit a copy of the current workspace.”

I’ll give the Workspace a new name. My Workspace name tells me which version of  
Vectorworks I made it for, and how many screens.

The Workspace Editor opens, first showing the menus editor tab. To make a new menu, drag 
the “New Menu” from the left of the box to the list of menus on the right. Select the new menu 
and rename it as desired. Then click and drag available commands from the left to the right 
under a new or existing menu. These do include existing Vectorworks commands as well as 
third-party commands, and the Workspace Editor now shows all of the new menu commands 
added in both 2008 and 2009.

Illustration 3

Illustration 2
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whatever sequence I like, including nesting 
tools “under” other tools. Custom icons can 
be added if desired. Unlike Menu commands, 
whole Tool Palettes can be moved when 
editing tools.

Once all of the tools and menus have been 
updated as desired, I’ll click the “OK” button. 
The Workspace is now saved and is available 
in the Tools>Workspaces menu.

Customizing the space to improve workflow 
becomes an ongoing thing. While working, 
the thought occurs that if only that tool was 
available without clicking to other tool 
palettes, work would move faster. I’ll pop right 
into Workspace Editor, make the change, and 
move on, now in a more seamless fashion.

Workspaces can be copied and shared between computers. If, however, custom scripts  
and tools are used, they will need to be copied along also. Where those custom scripts  
and Workspaces are located varies depending on the OS, but copy and move both the 
Workspace and the custom items.

The next step is to look at some of the other settings to create a default work environment.

Preferences

Preferences fall into two categories: those that define the way the program behaves in 
general, and those that are document-specific. While both can be changed at will, setting 
them up at the beginning is a good idea.

Program Preferences

The program preferences are found at Tools>Options>Vectorworks Preferences. Tabs 
across the top allow different options. Illustration #6 shows the “Edit” Tab. The only one of 
these I have a strong recommendation about is the “offset duplicate” choice. If checked on, 
any duplicate made will be offset from the original. If off, the duplicate will be in the same 
exact place as the original. Most of the time I’ll make a duplicate and then want to move it 
away from the original—but still have it related to the original. It seems easier to me to have 
the duplicate not offset before moving it. If I want to simply move a duplicate of an object, it  
is even easier in Vectorworks 2009, as I simply select the object and hold down the Option 
key on the Mac, which allows me to drag off the duplicate and place it wherever I wish.

Illustration 6

Illustration 7Illustration 5

Illustration 4
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 Worth mentioning is that here, as in most 
dialog boxes, holding down the command  
key reveals the available “hot key” commands 
that can be used. A key command means  
no mousing around, saving time, effort,  
and energy. 

I check and uncheck other preferences as  
I work. I have a set of scripts that toggle 
these preferences so that I don’t have to go 
through the dialog boxes. In the display tab, 
for example, there is a preference to show 
other objects while in groups (i.e., while 
editing a group of objects). I usually leave  
this unchecked, but sometimes seeing the 
rest of the drawing while editing the group is 
helpful. With a click on the script that resides 
in a palette in my custom Workspace, the 
preference quickly changes to show the  
rest of the drawing. Click again and the 
preference is reset. New in Vectorworks  

2009 is the option of having objects outside the group grayed when viewing a group. That 
seems to be the best of both worlds, and has become my usual choice (see Illustration #8).

 Again, personal choice determines the rest of the program preferences. I don’t use the scroll 
bars, so I turn them off. I prefer drawing on a white background since I’ll be printing on a white 
background and therefore turn the Black background off. I’ve heard varying arguments about 
the “Adjust flipped text” preference, with many people choosing to leave that option off. Text is 
generally better behaved with it off. However, I often use the Mirror Tool, and text mirrored is… 
well… mirrored. With this preference checked, the text flips properly. This includes text in 
Label Legends and other instrument-related processes. I’ll often build one boom stage right 
then mirror it to stage left. I leave “Adjust flipped text” checked.

New in Vectorworks 2009 are the preferences under the Interactive tab seen in Illustration #9. 
These preferences control how objects behave as the cursor interacts with them. Again, 
personal preference determines these choices.

Document Preferences

Document preferences are found at File>Document Settings> Document Preferences. 
These preferences are for things that might change for every document. Changes made here 
do not carry from document to document.

Illustration 8

Illustration 10

Illustration 9

In the “Display” tab, note the “use layer 
colors” choice. While I leave that turned  
off most of the time, turning it on does  
allow use of layer colors as discussed  
later in the book. The rest of these again  
are personal choice.

Dimensions

The second tab in Document Preferences  
is probably the most important. Defining  
how dimensions are handled is a critical  
part of the final picture. Associate dimensions 
are “connected” to the points they define.  
If the points change, the dimension also 
changes. I leave that checked on. I also  
want the dimensions to go into their own 
class for attribute and visibility control, so  
I check that as well.

Dimension Standards allow the choice  
of what the dimensions will look like. 
Vectorworks provides several Architectural 
Standards, or custom dimension choices  
can be created. 
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In the way I was taught to draft, the dimension was inset into the dimension line. Witness lines 
were offset from the object a small amount. Markers at the end of the dimension lines were 
likened to “exclamation points” in that they draw attention to what the extent of the dimension 
actually is. I liked a custom half tic. All of these “custom” choices are defined via the Custom 
button, and saved. I have two standards that I use for different situations. Once saved in the 
default document, they are available in any new document. They can also be imported into 
any other document via the Document Preferences using the Import… button as seen in 
Illustration #10.

Back in the Document Preferences Dialog Box, the Resolution Tab deals with how the output 
of the document will look. Some are display options and some are print or output options. I set 
them as in Illustration #11, but they should be set according to personal choice. See the Sheet 
Layer and Printing sections later in the book for further discussion of these options.

Clicking OK sets these options and I can move on to set up the rest of the drawing environment. 

Grids

Looking at the Drawing Window, a grid of blue lines is evident. In the 2D view, called Top/Plan 
in the Views menu, they are aligned with the X axis, running screen left and screen right, and 
the Y axis, running up screen and down screen. The origin defines where the X axis and the Y 
axis meet, and it defines the starting point for the rulers in the window. By default, the origin of 
a drawing is set at the center of the drawing space. While it is possible to change the origin of 
the grid, I find it easier in the long run to build the drawings around the default origin. It also 
seems safer in later uses of the file, as combining or referencing files with the default origin 
produces more consistent results.

In the corner where the rulers meet is a tool that will set the origin to the next click. There  
is also a menu command with a key command that will do the same thing. My suggestion  
is never use them.

 

I tend to build my drawings so that, in a proscenium theatre for example, the Center Line (CL) 
corresponds to the X (vertical) axis,and the Plaster Line (PL) corresponds to the Y (horizontal)
axis. Where the two meet is 0,0. In an arena or thrust style theatre, where the two Center 
Lines meet might be the 0,0 point. Whatever theatre I’m in, there is some defined 0,0 point.  
I’ll build—or import—the drawing around that point rather than haphazardly drawing the  
space then moving the origin to a new place.

Illustration 11

Illustration 12
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