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Introduction

This manual builds on the Vectorworks Essential manual. The Essential manual is designed  
to show you basic concepts of Vectorworks such as 2D drafting, simple 3D modelling and 
basic file organisation. If you are unfamiliar with these concepts then you should get the 
Essential manual and complete it before you go any further. 

In this manual we will be working through a series of exercises then we will work on a   
specific project. This project will:

Show you how to do more advanced 3D modeling by making street furniture;• 

Show you how to use some of the advanced 3D tools for creating curved 3D models;• 

Show you how to move through a series of tools an commands to get the model that      • 
you want.
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How to Use this Manual

Here are some things that will help you to use this manual better:

Spend the time to work through the manual. The information in this manual will not find it’s 
way into your head if you don’t complete the exercises. Reading the manual is good, reading 
the manual and watching the movies is better, reading the manual, watching the movies and 
completing the exercises has the best results. Watch the movies, try the exercise and then 
play the movie again. 

Instructions for you to complete are shown like this.• 

Tips: Useful tips are shown like this

Measurements for you to use are shown in both Metric and Imperial. Metric measurements  
are shown first, Imperial measurements are show second in brackets. If you are  using metric, 
don’t type in the imperial measurements; if you are using imperial, don’t type in the metric 
measurements, just type in the measurements inside the brackets.

This manual comes as a hard copy with 1 CD.  

There are two exercise folders on the CD. One is called “3D Modeling Exercises Imperial”, the 
other is called “3D Modelling Exercises Metric”. Copy the exercise folder that you want to use  
to your computer.  Place the exercise folder in a location to make it easy to open the files, 
such as “My Documents”.

Save any training files that you work on to your exercise folder.

When you want to play a movie that is shown in the printed manual, insert the 3D Modelling  
CD into your computer’s CD player and double click on the file on the CD called “3D Modeling 
Tutorial.pdf”. This is your electronic copy of the manual and it contains links to all the movies.  
To play a movie from the electronic copy of the manual, move your cursor over the movie icon 
(the cursor changes shape) and click once. When the movie is finished it will automatically  
close. Use Adobe Arcobat Reader to read the manual and play the movies, use Vectorworks  
to do the exercises. 

This manual is intended to be used with the standard Vectorworks workspace. After you have 
completed this manual you can change back to your normal workspace and carry out the 3D 
modeling you want. 

Go to the menu bar.• 

Choose Tools > Workspaces > Standard. • 

1.0 Simple 3D Modeling 

1.1 Extrusions
To create an extrusion start with a solid 2D element—for example, a rectangle, a circle, etc. If  
you want to render the object, it has to be a solid object before you extrude it. It can be a line, 
rectangle, polygon, or any 2D shape.  

Extrusions follow a few rules:

Extrusions are always based on the 1. 
viewing plane. The seem to come out 
of the screen  at you. If you are in 
Top/Plan or Top, the extrusion will be 
in the Z direction only. If you are in a 
front view, the extrusion will be in the 
Y direction only.

Extrusions always start at 0 on the 2. 
current working plane. If you haven’t 
set a working plane, then the 
extrusion will start at Z=0 on the 
current layer.

The extrusion is based on the 2D 3. 
shape and this 2D shape is stored    
by Vectorworks. You can use the 
command Edit Extrude from the Modify Menu to edit the 2D shape and change the 
extrusion or double click on the extrude to edit the 2D geometry.

You can edit the length of the extruded shape using the Object Info Palette, or double click 4. 
on the extrusion to edit the 2D geometry.
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Extrusion Exercise 1

The first rule of extrusions is that extrusions always come out of the 
screen at you. This means that you have to be aware of the view 
that you are in before you choose the extrude command.  

Open the file • 3D Model 1.sta 
from the exercise folder.

There are three equal rectangles • 
in the middle of the drawing. 

Make sure that you are in a Top/Plan view.• 

Go to the View Bar.• 

Click on the pop-up menu for the standard views.• 

Choose•  Top/Plan.

Select the first (left-hand) rectangle.• 

Go to the Menu Bar.• 

Choose  • Model > Extrude...

Extrude this rectangle • 2000mm (6’). This 
rectangle has been extruded towards you, that is, 
it has been extruded up.

Select the second (middle) rectangle.• 

Go to the View Bar.• 

Click on the pop-up menu for the standard views.• 

Choose•  Front.

In this view you can see how the first 
rectangle was extruded up in 3D.

Go to the Menu Bar.• 

Choose  • Model > Extrude...

Extrude this rectangle • 2000mm (6’).  
This rectangle has been extruded  
toward you—in the front view.

Select the last rectangle.  • 

Go to the View Bar.• 

Click on the pop-up menu  • 
for the standard views.

Choose•  Right Isometric.
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In this view you can see how • 
the first rectangle was extruded 
up in 3D and the second 
rectangle was extruded towards 
the front.

Go to the • Menu Bar.

Choose  • Model > Extrude...

Extrude this rectangle • 2000mm (6’).  
This rectangle has been extruded  
toward you—in the isometric view.

Try out the • Top/Plan view, and 
you will see how the three 
rectangles have been extruded 
in different directions.

Editing Extrusions

Vectorworks allows you to edit extrusions after they are made. This 
means you can make a quick extrusion and then go and edit it 
when you have more time. 

Open the file  • 3D Model 2.sta from 
the exercises folder.

Double click on the extrusion.  • 
Vectorworks will take you into an 
extrusion edit mode so that the 
original 2D shape can be edited.   

Remember that if you want to edit • 
most objects in Vectorworks, double 
click on it (not all objects are edited 
by double clicking on them).

This displays the 2D shape used to • 
create the extrusion.  

Notice the large orange button at the  
top right and the orange border around  
the drawing window. These show you  
that you are inside the editing area of  
the extrusion. 
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Add a circle to the 2D shape • 
as shown.

Click on the • Exit Extrude 
button on the top right of the 
drawing area.

You can see the results in 3D.• 

You can select several objects at the 
same time and extrude them. They 
don’t become a multiple extrude. 
Rather, they become a single extrude 
or a group of extruded objects. Edit 
Extrude will still display all the 2D 
shapes used to create the extrusion, 
and Ungroup will leave them as 
individual extrusions.

1.2 Multiple Extrude
A Multiple Extrude is quite different from the standard extrusion. If you select two shapes and 
choose extrude, you end up with the two shapes extruded, which looks like a group of 
extruded objects. A Multiple Extrude is used to create 3D forms that change shape from one 
end to the other, or change shapes in the middle. You can use two shapes to create a simple 
3D shape that changes shape from one end to the other, or you can use several shapes and 
make a sort of “skinned” object.  

There are some rules for using 
and creating Multiple Extrusions:

Extrusions are always based 1. 
on the viewing plane. The 
seem to come out of the 
screen at you. If you are in 
Top/Plan or Top, the extrusion 
will be in the Z direction only. 
If you are in a front view, the 
extrusion will be in the Y 
direction only.

Multiple Extrusions always 2. 
start at 0 on the current 
working plane. If you haven’t 
set a working plane then the 
extrusion will start at Z=0 on 
the current layer.

The Multiple Extrusion is based on the 2D shapes used to create it, and these 2D shapes 3. 
are stored by Vectorworks and can be edited. You can use the command Edit Multiple 
Extrude from the Modify Menu to edit the 2D shapes to change the Multiple Extrusion.  

The stacking order of the objects (front to back) determines the shape of the Multiple 4. 
Extrude.  The object that is at the back (or drawn first) is at the bottom of the extruded 
object. The object that is at the front (or drawn last) is at the top. The stacking order can 
be changed at any time by using the Send to Back or Send to Front commands in the 
Modify Menu.

You can edit the length of the extruded shape using the Object Info Palette.5. 
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Open the file  • 3D Model 3.sta from the exercises folder.

We are  going to draw a chimney shape, a shape that changes  
from the base to the top. We need to draw both the bottom  
shape and the top shape. 

Tip: The easiest way to create a rectangle of a 
specific size and position is to double click on the 
Rectangle Tool. This opens a dialog box for you to 
type in the size and position of the rectangle that you 
want to create.

Using the Rectangle Tool create a • 1000x750mm 
(40x30 in.) rectangle with the insertion point in the 
middle of the rectangle and the coordinates at 0,0.

Click on the • OK button.

Then draw a • 750x500mm (30x20 in.) rectangle 
on top of the first rectangle so that their centers 
line up, that is, they are aligned center/center.  

Click on the • OK button.

Make sure that you are in  • 
Top/Plan view.

Select both rectangles.• 

Go to the Menu Bar.• 

Choose • Model > Multiple Extrude...

Enter the extrude height as • 3500mm (11’8”). This 
will create a slender tapered extrusion. As with all 
extrusions, this object starts at 0 on the working 
plane and comes out of the screen at you.

Click on the • OK button.

In Top/Plan the object             • 
looks different.

A chimney has just been created so 
it will still be selected. If the Object 
Info Palette is not open, go to 
Palettes on the Menu Bar and 
choose Object Info. The Object Info 
Palette allows you to make changes 
to the size of the extrusion, ∆X ,∆Y, 
and the extrusion length.  
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Deselect everything by clicking • 
away from everything with the 2D 
Selection Tool, or tap the ‘X’ on 
your keyboard twice.  

Right mouse click on the top • 
rectangle (on a one button 
mouse, use control-click). 

Choose the option •  Send > Send 
to Back.  

Click on the • Exit Multiple 
Extrude Profiles button on the 
right side of the Tool Bar to see 
the results in 3D. As I noted 
earlier, Vectorworks uses the 
stacking order (the front-to-
back order) of the objects to 
work out which rectangle to put 
at the bottom and which one to 
put at the top.  

Double click on the edge of • 
the object. 

Right mouse click on the • 
bigger rectangle and choose 
Send > Send to Back.  

We want to change the height of the 
chimney. But we also want to see 
what the chimney looks like in 3D.

Go to the View Bar.• 

Click on the pop-up menu for the • 
standard views.

Choose•  Right Isometric.

You can see your chimney in 3D.  • 

The chimney should still be • 
selected, so go to the Object Info 
Palette and change the extrusion 
height to 1500mm (60 in.).

Double click on the edge of       • 
the object. 

Although you are in a 3D view, you 
are looking at the two 2D shapes 
used to make up the chimney.  
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Select both rectangles.• 

Go to the Menu Bar.• 

Choose • Modify > Align > Align/Distribute... 

Align the rectangles so that the center/tops • 
are aligned.

Click on the • OK button.

Click on the • Exit Multiple Extrude Profiles 
button on the right side of the Tool Bar.

You can see the results in 3D.• 

1.3 Simple Cafe Table
One of the important tricks with 3D modeling is 
learning to break your 3D model into managable 
chunks. To demonstrate what I mean, we will be 
creating this table. 

To make this table in one 3D object would be hard. 
However, you might notice that you could make this 
table from two multiple extrudes for the center leg 
with a simple extrusion for the top. 

Open the file • 3D Model 4.sta from the exercises folder.

We will start by creating the base of the table. • 

Use the create rectangle dialog box (by double clicking on  • 
the Rectangle Tool) to create two squares at 0,0.

The first square should be • 400x400mm (16x16 in.) with     
the insertion point at the center of the rectangle and the 
coordinates at 0,0.  

The second rectangle should be • 100x100mm (4x4 in.)      
with the insertion point at the center of the rectangle and     
the coordinates at 0,0.  
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Select both of these • 
rectangles.

Go to the Menu Bar.• 

Choose • 
Model > Multiple Extrude...

Leave the X and Y dimensions, and in the  • 
Extrusion field put in a height of 100mm (4 in.).

This creates the base portion of the leg for us.

Create two more squares at • 0,0 
using the same method that we 
used for the base portion.

The first square should be • 
100x100mm (4x4 in.) with the 
insertion point at the center of 
the rectangle and the 
coordinates at 0,0.

The second rectangle should • 
be 400x400mm (16x16 in.) 
with the insertion point at the 
center of the rectangle and the 
coordinates at 0,0.  

Select only the last two • 
squares. When you want to 
select more than one object, 
remember the multiple 
selection exercises that are 
covered in the quickstart guide 
to Vectorworks.

Go to the Menu Bar.• 

Choose • Model > Multiple Extrude...

Leave the X and Y dimensions and in the • 
Extrusion box enter an extrude height of 
600mm (24” in.).  

This multiple extrude is still 
positioned at 0 in the Z direction, 
so it needs to be moved up in 3D.  

Go to the Menu Bar.• 

Choose • Modify > Move > Move 3D...
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Move in the Z direction by • 100mm (4 in.).

Click on the • OK button. 

The middle part of the leg is now 
sitting on top of the base.

Now, for the top of the table:  

Change back to • Top/Plan view.

Create another • 750x750mm 
(30x30 in.)  rectangle with the 
insertion point  
at the center of the rectangle and 
the coordinates at 0,0.  

Go to the Menu Bar.• 

Choose • Model > Extrude...

Extrude the table top by • 50mm (2 in.).  

By default Vectorworks creates the 
extrusions on the ground, so, the 
table top has to be lifted up in 3D.

Go to the • Menu Bar.

Choose • Modify > Move > Move 3D...

Move the table top up in the Z direction • 
700mm (28 in.). 

Now the top is sitting on the leg • 
in the correct place. 

We should change views to the • 
3D model. 

This method of building up the model around the center of the drawing is the best way to 
create furniture and 3D models. It allows you to position objects in 3D space about a known 
point, so you can use actual distances to place things.  
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